Rabu, 21 Maret 2012

SETTING MIKROTIK UNTUK GAME ONLINE CAMPUR BROWSING

UPDATE 2012 MORE INTELEGENT MORE POWERFULL

Pada tutor kali ini saya coba uraikan settingan mikrotik untuk game online dicampur dengan kepentingan browsing (ngenet) agar berjalan serasi dan seimbang.
Note:
  • Script di bawah hanya berjalan pada mikrotik versi 3.30 ke atas.
  • Bandwidth yang diimplementasikan 1Mbps/256Kbps (SPEEDY)

Langsung ke TKP..!!!

Code:

/interface
set 0 name=speedy ----------->(public)
set 1 name=lan ----------------> (local)


/ip address
add address=192.168.0.200/24 interface=speedy
add address=192.168.1.1/24 interface=lan


/ip route
add gateway=192.168.0.1 -------->(alamat modem ADSL)


/ip dns
set primary-dns=222.124.204.34
set secondary-dns=202.134.0.155
set allow-remote-requests=yes


/ip fi nat
add chain=srcnat action=masquerade out-interface=speedy


INI ROUTING UNTUK GAME ONLINE:
/ip firewall mangle \
add action=mark-connection chain=prerouting \
comment="GAME ONLINE" dst-port=\
"1818,2001,3010,4300,5105,5121,5126,5171,5340-5352,6000-6001,6000-6152,7777" \
new-connection-mark="zar-goc" passthrough=yes protocol=tcp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
disabled=no dst-port="7341-7350,7451,8085,9600,9601-9602,9300,9400,9700,93\
76-9377,10001-10011,40000" \
new-connection-mark="zar-goc" passthrough=yes protocol=tcp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
dst-port="10009,13008,16666,28012,11011-11041,10402,11031,12011,12110,13413,15000-15002,15001,15002" \
new-connection-mark="zar-goc" \
passthrough=yes protocol=tcp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
disabled=no dst-port="16402-16502,18901-18909,19000,19101,22100,27780,29000,29200,39100,39110,39220,39190,49100" \
new-connection-mark="zar-goc" passthrough=yes protocol=tcp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
dst-port=14009-14010 new-connection-mark="zar-goc" \
passthrough=yes protocol=tcp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
dst-port="1293,1479,6100-6152,7777-7977,9401,9600-9602,12020-12080,30000,40000-40010" \
new-connection-mark="zar-goc" passthrough=yes protocol=udp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
dst-port=42051-42052,11100-11125,11440-11460 \
new-connection-mark="zar-goc" passthrough=yes protocol=udp

/ip firewall mangle \
add action=mark-connection chain=prerouting \
dst-port=14009-14010 new-connection-mark="zar-goc" \
passthrough=yes protocol=udp

GAME DIBUAT PREROUTING AGAR TIDAK BERLIKU DI TUBUH ROUTER
/ip firewall mangle \
add action=mark-packet chain=prerouting \
connection-mark="zar-goc"  \
new-packet-mark="zar-gopd" passthrough=no

INI ROUTING UNTUK GAME FACEBOOK
/ip firewall mangle \
add action=mark-connection chain=prerouting \
comment="GAME FACEBOOK" dst-port=843,9339 \
new-connection-mark="zar-gfc" passthrough=yes \
protocol=tcp

/ip firewall mangle \
add action=mark-packet chain=forward \
connection-mark="zar-gfc" disabled=no \
dst-address=192.168.1.0/24 new-packet-mark="zar-gfpd" \
passthrough=no

/ip firewall mangle \
add action=mark-packet chain=forward \
connection-mark="zar-gfc" new-packet-mark="zar-gfpu"\
passthrough=no src-address=192.168.1.0/24


INI PCQ UNTUK SPEED BAGI RATA
/queue type \
add kind=pcq name=DOWN \
pcq-classifier=dst-address,dst-port

/queue type \
add kind=pcq name=UP \
pcq-classifier=src-address,src-port


INI QUEUE UNTUK GAME ONLINE
/queue tree \
add name="2.GAME DOWN" \
parent=global-out priority=2


/queue tree \
add name="3.GAME UPLOAD" \
parent=speedy priority=2


/queue tree \
add name="1.GAME ONLINE DOWN" \
packet-mark="zar-gopd" \
parent="2.GAME DOWN" priority=2 queue=DOWN


/queue tree \
add max-limit=256000 \
name="2.GAME FACEBOOK DOWN" \
packet-mark="zar-gfpd" \
parent="2.GAME DOWN" priority=3 queue=DOWN


/queue tree \
add name="1.GAME ONLINE UPLOAD" \
packet-mark="zar-gopd" \
parent="3.GAME UPLOAD" priority=2 queue=UP


/queue tree \
add limit-at=0 max-limit=128000 \
name="2.GAME FACEBOOK UPLOAD" \
packet-mark="zar-gfpu" \
parent="3.GAME UPLOAD" priority=3 queue=UP


INI UNTUK LIMIT FILE EXTENSI, SEPERTI .EXE .RAR .YOUTUBE, DLL

/ip firewall layer7-protocol
add name="YOUTUBE DOWNLOAD" \
regexp="http/(0\\.9|1\\.0|1\\.1) \
[\\x09-\\x0d ][1-5][0-9][0-9] \
[\\x09-\\x0d -~]*(content-type: video)"
add name=EXE regexp="\\.(exe)"
add name=RAR regexp="\\.(rar)"
add name=ZIP regexp="\\.(zip)"
add name=7z regexp="\\.(7z)"
add name=WMV regexp="\\.(wmv)"
add name=MPG regexp="\\.(mpg)"
add name=MPEG regexp="\\.(mpeg)"
add name=AVI regexp="\\.(avi)"
add name=FLV regexp="\\.(flv)"
add name=WAV regexp="\\.(wav)"
add name=MP3 regexp="\\.(mp3)"
add name=MP4 regexp="\\.(mp4)"
add name=ISO regexp="\\.(iso)"
add name=3GP regexp="\\.(3gp)"
add name=MOV regexp="\\.(mov)"
add name=MKV regexp="\\.(mkv)"
add name="YOUTUBE STREAMING" regexp=youtube
add name=PORN regexp=porn
add name=TUBE regexp=tube
add name=VIDEO regexp=video
add name=MOVIE regexp=movie

INI ROUTING UNTUK EXTENSI

/ip firewall mangle
add action=mark-packet chain=forward \
comment="LIMIT EXTENTION" disabled=no \
layer7-protocol="YOUTUBE DOWNLOAD" \
new-packet-mark="YOUTUBE DOWNLOAD" \
passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol="YOUTUBE STREAMING" \
new-packet-mark="YOUTUBE STREAMING" \
passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=TUBE \
new-packet-mark=PORN1 passthrough=no
add action=mark-packet chain=forward disabled=no \
layer7-protocol=PORN \
new-packet-mark=PORN2 passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=VIDEO \
new-packet-mark=PORN3 passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MOVIE \
new-packet-mark=PORN4 passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MKV \
new-packet-mark=MKV passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MP3 \
new-packet-mark=MP3 passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MP4 \
new-packet-mark=MP4 passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=ZIP \
new-packet-mark=ZIP passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=EXE \
new-packet-mark=EXE passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=FLV \
new-packet-mark=FLV passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=ISO \
new-packet-mark=ISO passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MOV \
new-packet-mark=MOV passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MPEG \
new-packet-mark=MPEG passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=MPG \
new-packet-mark=MPG passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=RAR \
new-packet-mark=RAR passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=WAV \
new-packet-mark=WAV passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=WMV \
new-packet-mark=WMV passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=ISO \
new-packet-mark=3GP passthrough=no
add action=mark-packet chain=forward \
disabled=no layer7-protocol=7z \
new-packet-mark=7z passthrough=no

INI ROUTING UNTUK BROWSING (DOWNLOAD/UPLOAD)

/ip firewall mangle \
add action=mark-connection chain=prerouting \
comment=HTTP  dst-port=21,80 \
new-connection-mark="browsing-con" passthrough=yes protocol=tcp

/ip firewall mangle \
add action=mark-packet chain=forward \
connection-mark="browsing-con" disabled=no \
dst-address=192.168.1.0/24 \
new-packet-mark="download" passthrough=no

/ip firewall mangle \
add action=mark-packet chain=forward \
connection-mark="browsing-con" disabled=no \
new-packet-mark="upload" \
passthrough=no src-address=192.168.1.0/24

INI QUEUE UNTUK KEGIATAN  BROWSING-DOWNLOAD-UPLOAD

/queue tree \
add max-limit=128000 \
name="UPLOAD-BROWSING" \
packet-mark="upload" parent=speedy \
priority=4 queue=UP

/queue tree \
add max-limit=750000 \
name="1.2 HTTP-DOWN" \
parent=global-out priority=2

/queue tree \
add max-limit=750000 \
name="1.3 BROWSING DOWN" \
packet-mark="download" \
parent="1.2 HTTP-DOWN" \
priority=4 queue=DOWN

/queue tree \
add max-limit=512000 \
name="1.4 LIMIT EXTENTION" \
parent="1.2 HTTP-DOWN" priority=5

/queue tree
add name=YOUTUBE \
parent="1.4 LIMIT EXTENTION" priority=5
add name="YOUTUBE STREAMING" \
packet-mark="YOUTUBE STREAMING" \
parent=YOUTUBE priority=5 queue=DOWN
add name=MKV packet-mark=MKV \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=MP3 packet-mark=MP3 \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=MP4 packet-mark=MP4 \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=ZIP packet-mark=ZIP \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=EXE packet-mark=EXE \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=ISO packet-mark=ISO \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=AVI packet-mark=AVI \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=MOV packet-mark=MOV \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=MPEG packet-mark=MPEG \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=MPG packet-mark=MPG \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=RAR packet-mark=RAR \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=WAV packet-mark=WAV \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=WMV packet-mark=WMV \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=3GP packet-mark=3GP \
parent="1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=7z packet-mark=7z \
parent="1.4 LIMIT EXTENTION" priority=5 \
queue=DOWN
add name="YOUTUBE DOWNLOAD" \
packet-mark="YOUTUBE DOWNLOAD" \
parent=YOUTUBE priority=5 queue=DOWN
add name=PORN \
parent="1.4 LIMIT EXTENTION" priority=5
add name=PORN1 \
packet-mark=PORN1 parent=PORN \
priority=5 queue=DOWN
add name=PORN2 packet-mark=PORN2 \
parent=PORN priority=5 queue=DOWN
add name=PORN3 packet-mark=PORN3 \
parent=PORN priority=5 queue=DOWN
add name="MIVO TV" \
packet-mark="MIVO TV" parent=\
"1.4 LIMIT EXTENTION" \
priority=5 queue=DOWN
add name=PORN4 packet-mark=PORN4 \
parent=PORN priority=5 queue=DOWN

Kesimpulan:
1. Game online dirouting langsung ke alamat port game online dan menggunakan bandwith maksimal (unlimited) karena tidak terlalu memakan bandwith sekalipun game PB hanya butuh koneksi dengan trafic yang mulus.
2. Browsing dirouting pada port 80 dan 21 dan diberikan bandwith maksimal 750Kbps untuk download dan   128Kbps untuk upload dan tidak boleh melebihi dari itu atau game online akan nge-lag.
3. Limit Extensi dirouting berdasarkan layer 7 protocol dan diberikan maksimal bandwidth 512Kbps dan tidak boleh lebih dari itu atau browsing dan game online akan terganggu.






PERHATIAN:
  • Tutorial di atas untuk 10 PC saja dengan Bandwidthnya 1Mbps,.
  • Jika PC lebih dari 10 dan BW tetap 1 MBPS, maka pada queue tree download menjadi 512Kbps dan limit extensi menjadi 256Kbps.
  • Jika mempunyai BW 2Mbps ke atas, silahkan 2x lipatkan saja pada queue tree-nya atau gunakan logika anda sendiri.



Kamis, 15 Maret 2012

CARA MENGATASI MASALAH KONEKSI WIRELESS WPA2 SECURITY DI WINDOWS XP

Kenapa wifi di windows XP tidak bisa terkoneksi???  bahkan muncul pesan:
“Windows is unable to connect to the selected network. The network may no longer be in range. Please refresh the list of available networks and try to connect again.”
Atau muncul pesan bahwa windows XP tidak mengenali enkripsi yang diminta, windows hanya mampu mengenali enkripsi WEP saja dengan jumlah bit 128 atau 256.

Penyebab:

Hal itu terjadi karena tidak tersedianya feature security yang sesuai dengan ketentuan pada perangkat wireless. Windows XP, secara default hanya menyediakan dua jenis type security wireless, yaitu WPA dan WPA-PSK. Jika security yang anda tentukan pada perangkat wireless adalah WPA2, maka tentu saja windows xp tidak atau belum mengenali jenis security/enkripsi tersebut karena jenis security WPA2 itu diciptakan setelah windows XP beredar. Jadi, sangat wajar jika beberapa Windows XP belum memasukkannya dalam feature wireless yang tersedia.

Solusi:
1. Update Windows XP anda (tidak mau??? takut kena genuin advantage???)
                     atau
2. Download program di bawah ini:

LINK 1 WIN XP WRL UPDATE

LINK 2 WIN XP WRL UPDATE

Setelah itu restart laptop kamu dan coba lakukan koneksi wireless-nya lagi.

Selamat mencoba.

Rabu, 14 Maret 2012

CARA SETTING CCTV KONEKSI KE INTERNET

HARUS DIPERHATIKAN DULU...!!!!!!

1. Cahaya
  • Jangan memasang CCTV dengan sumber cahaya secara langsung di depannya dan jangan menempatkan kamera inframerah saling berhadapan untuk menghilangkan risiko pencahayaan. 
  • Hindari pemasangan kamera ke arah cahaya yang dapat menyilaukan.
  • Gunakan infra merah untuk kondisi yang sangat gelap atau gunakan fitur camera B/W (black-white).
2. Tempatkan kamera di tempat yang strategis.
3. Usahakan agar pengkabelan kamera tidak terlalu jauh dari DVR untuk hasil kualitas video yang baik dan sistem instalasi kabel jangan digabungkan dengan jaringan listrik yang bertegangan tinggi untuk menghindari imbas elektromagnetik.


SETTING DVR

1. Sambungkan DVR ke monitor komputer beserta mouse-nya.
2. Klik kanan mouse, selanjutnya akan muncul menu konfigurasi. Kemudian pilih setup. Jika menanyakan password, biasanya password-nya: 0000 (nol 4x) atau tergantung dari merk DVR-nya.
3. Pilih Network Setup dan pilih saja LAN.


-  IP address disesuaikan dengan IP pada modem ADSL/Router.
- Untuk DNS sebagai contoh saya gunakan DNS open dns. Menggunakan DNS google juga bisa: 8.8.4.4

4. Pilih HTTP Setup dan tentukan port -nya

Port bebas diberikan asal anda ingat. Sebagai contoh saya berikan 7500

5. DDNS

Jika kamu punya akun DDNS di dyndns.org sebaiknya masukkan alamatnya pada menu DDNS setup.

6. Setting modem ADSL


Pada modem ADSL (saya contohkan TP-Link TD-8817) setting NAT-nya agar dapat diakses di luar jaringan atau diakses jarak jauh melalui internet.
Coba perhatikan port yang digunakan harus sesuai dengan port pada DVR, begitupula IP address-nya.

7. Jalankan perintah ping pada komputer yang tersambung dengan jaringan ke DVR, yaitu 192.168.1.10. Harusnya akan melakukan reply dengan sukses.

8. Buka browser dan isi alamat  192.168.1.10:7500, maka akan terbuka halaman dengan tulisan: 
- open with internet explorer
- download remote monitor client
Silahkan gunakan internet explorer, namun security level harus dirubah menjadi custom level dan izinkan active x controlnya.
Atau dengan software bawaan software-nya dengan cara men-download monitor remote client.

9. Dengan internet explorer coba akses dengan IP public kamu (jika tidak tau coba ke www.whatismyip.com), contoh http://222.124.204.5:7500. Harusnya bisa langsung tampil gambar dari kamera. Atau dengan akun DDNS kamu, contoh http://bdgjarkom.dvrdns.com:7500

10. Jangan lupa berikan password untuk DVR kamu pada menu setup------>account


Selamat mencoba.

Rabu, 07 Maret 2012

SETTING WIRELESS AP & RANGE EXTENDER TP-LINK UNTUK DI GEDUNG 2 LANTAI

Tutorial kali ini ane coba share koneksi wireless untuk di gedung 2 lantai dengan asumsi:
- di lantai 1 modem dan AP berada
- di lantai 2 range extender berada
- AP akan melakukan penyebaran sinyal wireless dan dikuatkan oleh range extender

Topologi:

MODEM------------AP)))))))))))))))))))))))))))) RANGE EXTENDER))))))))))))))))))))))CLIENT
                                    ))))))))))))))))))CLIENT
Langkah2:

1. Setting modem seperti biasa dengan IP lokal modem 192.168.1.1
2. Setting IP PC untuk media setup dengan IP 192.168.1.2 SNM 255.255.255.0 (gateway nggk perlu diisi)
3. Setting AP:
Hubungkan AP dengan PC memakai kabel LAN. Pada browser ketikkan alamat 192.168.1.1 (alamat AP default TP-Link), jika muncul dialog login, masukkan username=admin dan password admin, maka akan muncul webpage AP TP-LINK.


Pada menu Operation Mode, pilih "AP" kemudian save


Pada menu Network---Lan isikan IP 192.168.0.1 kemudian save dan AP akan me-reboot otomatis.
Jangan lupa ganti IP di PC dengan 192.168.0.2 SNM 255.255.255.0 (gateway nggak perlu diisi)

Masuk lagi ke AP melalui browser dengan memasukkan alamat 192.168.0.1 kemudian lanjut ke menu berikutnya.


Pada menu Network-----Wan, pilih wan connection type=static IP dan masukkan IP address sesuai dengan segmen modem, yaitu: IP=192.168.1.1 SNM=255.255.255.0 GW=192.168.1.1 DNS1=192.168.1.1 DNS2=8.8.4.4 kemudian save.


Pada menu Wireless---Basic Setting, isikkan SSID (nama hotspot-nya), misalnya saya beri nama "yum". Pastikan channel yang dipilih adalah channel yang belum dipakai oleh pengguna wireless lain, misalnya saya kasih channel 3. Biarkan Power nya 26dBm agar lebih maksimal dan pilihan standar wirelessnya 54Mbps (g). Kemudian save.


Pada menu Wireless---Wireless Mode, pilih saja access point dan centang enable SSID broadcastnya agar bisa dilihat nama hotspotnya. Silahkan save.


Pada menu Wireless---security settings, pilih enkripsi password yang kuat, misalnya saya pakai WPA-PSK dengan jenis enkripsi AES/TKIP dengan password "rahasiah".


Pada menu Wireless---Distance Setting, pilih saja adjust option indoor, karena untuk di dalam ruangan, biasanya pilihan ini akan melakukan penyebaran sinyal  wireless sebanyak180 derajat. Silahkan Save.


Reboot AP-nya pada menu System Tool---Reboot.

3. Hubungkan AP dengan modem ADSL.

4. Siapkan Range Extender, kemudian hubungkan dengan PC.
Pastikan PC tetap pada IP 192.168.0.2 karena range extender IP-nya biasanya 192.168.0.254
Pada browser isikan IP 192.168.0.254, maka akan muncul halaman/webpage range extender seperti di bawah ini.


Set IP-nya seperti gambar di atas. Untuk gateway-nya bisa juga dengan mengisi IP 0.0.0.0 karena range extender hanya melakukan penguatan sinyal saja dan AP sebagai bridge ke modem ADSL.


Operation Mode dipilih "range extender" (jangan pilih access point) kemudian klik tombol "survey". Maka akan muncul seperti gambar di bawah:



Perhatikan SSID AP yang telah disetting tadi. Tadi SSID nya adalah "yum", klik tombol connect yang berwarna biru kemudian "save".


Selanjutnya pada menu Wireless---Wireless Setting, silahlan cocokkan security setting-nya persis seperti pada AP. kemudian save dan reboot range extendernya.

Lakukan scanning dengan laptop, di lantai 1 dan lantai 2. Perhatikan signal strength dan bedakan sinyal di lantai 2 apabila range extender diamatikan, apakah sinyal AP lemah atau tidak????
Sedangkan bila range extender dihidupkan, apakah sinyal AP menjadi kuat atau tidak????.
Atau anda bisa melihat status pada perangkat range extender. Pada keterangan status, tertera AP dengan SSID "yum".

Perlu kesabaran, koneksi antara AP dan range extender membutuhkan beberapa menit.

Selamat mencoba.

MEMBAGI BANDWIDTH SAMA RATA SECARA OTOMATIS DI MIKROTIK RB750

1. Masukkan Kabel komputer ke port nomor 3 di mikrotik RB750. Sedangkan Modem ADSL yang sudah terseting dengan alamat IP 192.168.1.1 dihubungkan ke port nomor 1 pada RB.

2. Biasanya IP di komputer diset DHCP aja dulu (obtain IP address automaticaly)

3. Jalankan winbox kemudian deteksi IP-nya dengan cara klik sebelah tombol connect. Biasanya tertera alamat 192.168.88.1, kemudian isi username dengan admin dan password kosongkan saja, lalu klik connect.

4. Kllik "new terminal". Pada terminal ketik "setup", kemudian tekan tombol "r" kemudian "y", maka RB akan melakukan reboot dan winbox akan terputus koneksinya (close aja dulu)

5. Isi IP pada komputer: 192.168.0.1 SNM: 255.255.255.0 GW: 192.168.0.1 DNS: 192.168.0.1

6. Jalankan winbox lagi, kemudian deteksi seperti pada langkah 2, maka akan terdeteksi IP 0.0.0.0. Klik connect, jika muncul dialog, klik saja "remove configuration".

7. Klik "new terminal" dan silahkan copy-paste script di bawah ini di "new terminal":

/interface
set 0 name=wan
set 2 name=lan

/ip address
add address=192.168.1.200/24 interface=wan
add address=192.168.0.1/24 interface=lan

/ip route
add gateway=192.168.1.1

/ip firewall nat
add chain=srcnat action=masquerade out-interface=wan

/ip dns
set primary-dns=202.134.0.155
set secondary-dns=8.8.4.4
set allow-remote-requests=yes


/ip firewall mangle
add chain=forward src-address=192.168.0.0/24 action=mark-connection new-connection-mark=users-con
add connection-mark=users-con action=mark-packet new-packet-mark=users chain=forward

/queue type
add name=pcq-download kind=pcq pcq-classifier=dst-address
add name=pcq-upload kind=pcq pcq-classifier=src-address

/queue tree
add parent=lan queue=pcq-download packet-mark=users
add parent=wan queue=pcq-upload packet-mark=users


(jangan di-copy-kan sebaris-sebaris, karena IP RB masih 0.0.0.0, nanti RB akan disconnect...!!!!!)

8. Reboot RB-nya.

Hasilnya:
Bandwidth akan terbagi rata secara otomatis.
Misalnya anda punya kecepatan 1 Mbps
- Bila user cuma ada 1, maka kecepatan akan full 1 Mbps
- Bila user ada 2 , maka kecepatan akan dibagi dua, yaitu 512 kbps
- dan seterusnya sampai rata.


Selamat mencoba.